cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

How to update server from TLS 1.0 to 1.2

My credit card provider requires my server be upgrade TLS 1.2...

 

How do I get Godaddy to upgrade my hosted server to be compatible?... I log in to my Godaddy account and can find no way to do this?... there is no way to contact them via chat?... is my only option to call them? 

17 REPLIES 17
Super User I Super User I
Super User I
Solution

Re: How to update server from TLS 1.0 to 1.2

I just had a chat with GoDaddy about this yesterday and I was advised that TLS 1.2 and HTTP/1.1 is good to go! Smiley Wink

 

 

Judith
"I failed my way to success." ~Thomas Edison

Re: How to update server from TLS 1.0 to 1.2

I recently received an email from my payment gateway - CCAvenue to upgrade/configure our systems to TLS 1.2.

 

Can you please help me with this. I could not find a way out on GoDaddy.

I won't be able to process any transactions from my customers unless TLS 1.2 is not updated.

 

Thanks,

A

New

Re: How to update server from TLS 1.0 to 1.2

did you ever resolve this issue?  Im scrambling to figure out how to get TLS1.2 working on my godaddy hosting account.  Thanks!


@shopfiranji wrote:

I recently received an email from my payment gateway - CCAvenue to upgrade/configure our systems to TLS 1.2.

 

Can you please help me with this. I could not find a way out on GoDaddy.

I won't be able to process any transactions from my customers unless TLS 1.2 is not updated.

 

Thanks,

A


 

Re: How to update server from TLS 1.0 to 1.2

Has anyone got the solution to actually post for us not getting any help from GoDaddy Tech support?!  My credit card processor and I are not happy that GoDaddy knows this is an issue with web hosting and we are told we have to "upgrade" in order to be able to fix this crap! PLEASE POST THE ANSWER HERE! NOT FIXED for us using web hosting cPanel!

TLS 1.2 Support in Windows Hosting

The current Windows hosting environment has PHP 5.4 as it's highest level which in turn only provides OpenSSL version 0.9.8y.

 

PayPal is requiring customers to now use TLS .1.2 which is provided by OpenSSL 1.01.  PayPal's sandbox environment will now only work with TLS 1.2 and their production environment is slated to require TLS 1.2 by June 30, 2017.

 

What is GoDaddy's plan for providing its Windows hosting customers with a higher level of PHP, OpenSSL and TLS that will allow them to continue using PayPal on their websites?

Re: How to update server from TLS 1.0 to 1.2

"Good to Go" is a pretty general term.  Windows Hosting is for sure NOT good to go.  It is currently PHP 5.4, OpenSSL 0.9.8y which I believe supports only TLS 1.0.

 

Does anyone out there have a definitive answer on when GoDaddy will support TLS 1.2 in their Windows hosting environment?

Re: How to update server from TLS 1.0 to 1.2

And how does one make this switch?

Re: How to update server from TLS 1.0 to 1.2

This is not a solution.  GoDaddy's Windows hosting DOES NOT CURRENTLY SUPPORT TLS 1.2.

 

Does anyone actually know when GoDaddy will support TLS 1.2 in their Windows hosting environment?

New

Re: How to update server from TLS 1.0 to 1.2

I'm having the same issue on VPS Server. I contact Godaddy and they would help me but after an hour on the phone they sent me this document. I followed instruction which were straight forward WHM but didn't make a difference on my website System Status still says it's at version 1.0.

https://documentation.cpanel.net/display/CKB/How+to+Adjust+Cipher+Protocols

 

Anyone else worked out how to get this to work as currently I can't operate my ecommerce business cause its not accepting payments.

Re: How to update server from TLS 1.0 to 1.2

Can anyone help me with this? I have just received the email from GoDaddy. What do I need to do? Thank you

Moderator
Moderator

Re: How to update server from TLS 1.0 to 1.2

If you still need assistance with this, please reach out to our live support teams at your earliest convenience.  Thanks.  

 

MPC

Re: How to update server from TLS 1.0 to 1.2

Did you get this to work TLS 1.2  having the same type problem with propay.com

Are you using Classic Asp or PHP

How change to change Secure SSL/TLS Settings for incoming and outgoing server .

I'm trying to change my  Secure SSL/TLS Settings for incoming and outgoing server from n1plcpnl.prod.ams1.secureserver.net . to mail.mydomain.com,coz its difficult to memorise when configuring mobile phone for emails.

Re: How to update server from TLS 1.0 to 1.2

Your "Solved" answer makes no sense at all Muse. Google has steps on how to change server configuration, but when you try to do that it warns by saying that this may lead to crashing of the server. Now who in his right frame of mind would take that risk? Why can't Godaddy automatically upgrade it for all of us considering TLS 1.0 is hackable and not secure?

 

Authorize.net will stop payment transactions from Feb and we still have no response from Godaddy on this, just a Fake Solved sign to the question.

Moderator
Moderator

Re: How to update server from TLS 1.0 to 1.2

Hi @mohitanand and all other community members chiming in on this thread. @Muse answer is correct but let me explain more. All of our current shared hosting plans have TLS 1.2 installed. If you are on one of our older hosting plans, you need to upgrade to one of our newer platforms. If you get a VPS or Dedicated Server you can install whatever version of TLS that you need. 

KayJay - GoDaddy | Community Moderator
24/7 support available at x.co/247support

Re: How to update server from TLS 1.0 to 1.2

Hey Guys,

 

I just called Godaddy support. I ran my site on the Certificate Checker  . The report shows the following for my Ultimate Linux Hosting with cPanel hosting plan.  

 

tlstls.png

Here's the takeaway per my call with support.

  1. Available = Usable
  2. Support told me that the prompts from my payment gateway company are not correct. Our site has TLS version 1.2.  There should be no issue.   

How the heck do you fix the issue if one party says there's a problem and the other says there is no problem. 

 

 

 

Re: How to update server from TLS 1.0 to 1.2

Talked to the Payment Gateway - They tell me that the issue is browser specific.  The issue appears with with 

  1. Edge Browsers
  2. Safari Browsers

Transactions are 100% solid with Chrome. 

 

UG.