• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution

    Wordpress Managed PHP Version

    How to change PHP Version for GoDaddy Wordpress Managed it  need two be  update  because new woocommerce plugins recommend PHP Version two be 5.6. in  MySQL version need two be 5.6     wil this be  Automatic fix   in  MaxMind GeoIP Database: need fix  ps before i buy a new web hosting will this wordpress Managed be Automatic update two new PHP version 

    1 ACCEPTED SOLUTION
    Former Employee

    Hey folks, just wanted to let you know that PHP 7.2 is now available on all Managed WordPress sites.  You can change your PHP version in your Hosting dashboard.  Here are a couple screenshots:

     

    Screen Shot 2018-10-10 at 3.28.31 PM.pngScreen Shot 2018-10-10 at 3.28.46 PM.png

     

    Thanks,

    Gabe

     

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    View solution in original post

    155 REPLIES 155

    +1 this upgrade is desperately needed! Wondering if it would have been better to stick with regular c-panel...I do like managed WP for clients though...

    New

    need at least 5.5 for constant contact plugin

    Former Employee

    Hello @cds@CryptoIsKey@rzelnick & @joeelectronics, great questions.  We have hardware on order to upgrade our object caching layer to Redis.  This will also allow us to upgrade our PHP version to 5.6.  We plan to update our MySQL version soon after.

     

    Thanks!

    Gabe

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    I just enrolled with godaddy/wordpress and to need woocommerce.  When? For those who have been using for awhile, how are you currently doing sales?  Thanks

    @tonyawilhelm For simple ecommerce websites without a shopping cart/login functionality forms may be a way to go. Formstack works well for these purposes. Even Gravity Forms can be a good WordPress specific solution.

     

    For sites with large inventory (10-1000) products woo is good too but it can become very complex. A hosted ecommerce solution like Shopify is another great option.

     

    BTW in regards to the PHP version discussion: "RECOMMENDED" does not mean "REQUIRED". Slightly older versions of PHP are fine as long as WordPress core requirements are being met that should be enough.

     

    The risk of a security vulnerability is MUCH higher with what's installed on WordPress than the underlying infrastructure. Since there are most likely many dependencies with a new version of PHP, this has to be handled very carefully. In some ways I depend on Managed WordPress to handle these tricky dependencies and put the PHP version out of sight out of mind.

     

    If you install software that REQUIRES PHP 5.6 then Managed WordPress from GD is not for you -- at least not yet. I'd think also releasing a road map on when any new version of PHP is installed is proprietary information I'd not like shared on a public forum like this. My check on ManagedWP tells me PHP 5.4.42 is being used -- it's about a year old now - and is end of life. If I was a betting man I'd think by end of 2016, PHP 5.6 will be activated on Managed WordPress.

     

     

     



    Alex Sirota, PMP - NewPath Consulting - Schedule some time with Alex
    "At the moment of commitment, the universe conspires to assist you." -Johann Wolfgang von Goethe

    Minimum Requirements

    The first step in setting up your WooCommerce-powered online store is to install WordPress and the WooCommerce plugin itself. But before doing so, you should check that your hosting environment meets our minimum requirements. These are:

    • PHP 5.6 or greater
    • MySQL 5.6 or greater

     

    Gabe, Feed them social says higher v. of PHP required. 

    Here is what I see in my managed wordpress account (exchangeclubofindianriver.org)     WP Statistics Disabled — You are running an unsupported version of PHP.

    WP Statistics has detected PHP version 5.3.24 which is unsupported, WP Statistics requires PHP Version 5.4.0 or higher!

    Please contact your hosting provider to upgrade to a supported version or disable WP Statistics to remove this message.

    New

    Here is my concern. GoDaddy wants it's clients to continue using a version that is no longer supported and creates a security risk for it's clients using the 'Managed WordPress' environment. I was sold that environment because of previous security issues only to put myself in the same position. There's been no compensation and purchasing a new plan or moving my managed to my current shared host.

    http://php.net/supported-versions.php

    Hey @mr910

     

    Appreciate the follow up. Regarding your security concerns with PHP, I'll forward your feedback over to our engineers. In the meantime, I just wanted to assure you that our Managed WordPress environment is very secure. Risks to a WordPress site tend to come more often from plugins, themes, and user practices; not from PHP vulnerabilities within the environment.

    As for your mention of compensation; I'm not sure what the exact situation was that had occurred in your account, but if there's a concern of needing to be compensated for the matter then I would recommend reaching out to our live support so our team can help review the matter and assist. They'll be more than happy to try and make this right.

     

    CG - GoDaddy | Community Moderator
    24/7 support available at x.co/247support

    I completely agree! I HAVE HAD security issues, and now I know why. I feel totally lied to, mislead and really really mad. We should have been better taken care of here, and if I could leave I would!

    +1.  GD WP Managed needs urgently to be upgraded to PHP 5.6

    Please provide the schedule.

    I have an online store which is not syncing. Urgently need the upgrade. If this does not get resolved, I need to take my business elsewhere and when I do that, I will take my additional 3 websites as well. 

    I was shocked to learn the Managed WordPress PHP version is so out of date. This is a HUGE issue for so many reasons, including security!! A vital plugin that I need requires 5.5 or higher, and the ONLY reason I can't use it is because my hosting company (YOU) is so behind????? Whaaaa????? When will it be updated GoDaddy?????

    New

    When will PHP be updated? I'm having major issues with Woocommerce extensions. Woocommerce suggests updating. But seriously! Why are we still on 5.4??? When can we expect to be updated? And why do you have a section in the cPanel PHP Selector where we can "seemingly" select a newer version, yet at the same time you clearly write: Changing php modules and php options via PHP Selector for native php version is impossible. What's that about?

     

    Please sort this out ASAP!!

    Yes, we need to know when this will be updated ASAP.  We have a number of sites that use Managed WordPress with Woocommerce and need the php version updated to at least 5.5.  WHY are these servers so outdated on the php version?

    Former Employee

    @Links @raindc

     

    Hey folks, thanks for commenting.  Checkout my update above, we're actively working on upgrading our Object Cache and PHP version.

     

    In the meantime I recommend reaching out to the WooCommerce team.  WooCommerce states they require PHP 5.2.4 or greater: https://wordpress.org/plugins/woocommerce/installation/  If their product isn't working with their required version they should update the version required or fix the issue.

     

    Gabe 

     

    Gabe

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    Actually you should look at this link on the Woocommerce website:

    https://docs.woocommerce.com/document/server-requirements/

     

    Also, the Constant Contact plugin requires 5.5 or above.

    Former Employee

    @raindc thank you!  That helps, thanks for the clarification.  I'll reach out and ask them to update the plugin requirements in the WordPress repository.

     

    Gabe

    Gabriel A. Mays
    Head of WordPress, GoDaddy
    Former Employee

    Hi @Links

     

    You mentioned cPanel.  I'll pass along your comments, but I recommend starting a new thread on your cPanel issue because this is a Managed WordPress thread.  Hope this helps!

     

    Gabe

    Gabriel A. Mays
    Head of WordPress, GoDaddy

    Ok - so it is now into October - Any update as to the timeline on this

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Advocate I

    Agreed - I've already had a couple of serious issues with my Managed WordPress site becoming glitchy, slow and unstable because of this old software.

     

    The sales department sold me on Managed WP and explained that it would be the latest, fastest and greatest product to host my WP site, but now I so regret buying it and wish I'd gone with my gut and chosen cPanel instead. At least cPanel allows a lot of freedom of control; my other sites on cPanel seem to run a lot faster, too. Smiley Sad

     

    Things are getting worse by the week with the old PHP version, I sure hope this behind the scenes upgrade happens sooner rather than later, I can't afford to have my site down this often.