Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
rchimes
New

WordPress Test Site

 I set up, or rather tried to, a test website using godaddy/wordpress, using the tools presented to me by Godaddy. Everything was in a foreign language, Greek I think but could be Russian. I translated the page to English and selected English as my Language to use. However, everytime I introduce some new or ask the system to generate it I can't b****y readit! How do I get the system to recognise that I am english and don't speak Greek (nor Russian)!

1 ACCEPTED SOLUTION
MrVapor
Super User 2020

@rchimes 

 

It sounds like the language needs to be set correctly in WordPress itself.

 

  • Log into your WordPress Dashboard.
  • Click Settings in the navigation menu, then click General
  • Click the drop-down menu next to Site Language, and choose your preferred language.
  • Click Save Changes. At this point you will see the website displayed in the language you selected.

 



I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community


View solution in original post

1 REPLY 1
MrVapor
Super User 2020

@rchimes 

 

It sounds like the language needs to be set correctly in WordPress itself.

 

  • Log into your WordPress Dashboard.
  • Click Settings in the navigation menu, then click General
  • Click the drop-down menu next to Site Language, and choose your preferred language.
  • Click Save Changes. At this point you will see the website displayed in the language you selected.

 



I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community


View solution in original post