• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Highlighted
    New

    Apache2 Linux

    Hi I'm new to website development and I am trying to configure a number of websites from my home based server using Apache2 and Linux Mint. I've checked with My ISP to see if it is allowed and it is.

     

    I have setup three new websites in addition to the 000-default page.I have created the Virtual Host config files in sites-available and have added the sites to Host.conf. Internally(on the server in a browser) they are all working fine - I can access all four sites using localhost or the URLs I've configured them with -tested with and without the www. prefix and all seems fine. The four sites are just basic HTML scripts with different headers and different one line body.

     

    I've added Listen 8090 to Listen 80 on my ports.conf file and have opened port 80 and 8090 on my firewall and have updated Port Forwarding on my router and tested they are open using PortCheckTool. The two ports are open and every other port is locked out so that seems good too.

     

    I've tried to configure a GoDaddy domain name to direct activity to one of these sites. The domain name that works internally (on the server in a browser) is the same as my GoDaddy domain name I've bought. I've been into my GoDaddy account and pointed this domain at my external IP address (tried also adding port to forwarding 8090 as well as leaving port number as default). However when I access this domain from my mobile phone using 3G with WIFI turned off I just get sent to the 000-default homepage.Same using default Port 80 and with Port Forwarding to 8090. I have script for both 80 and 8090 in my site config files in sites-available directory.

     

    So the connection is getting to the server, ports are OK, it's just that apache2 doesn't redirect the GoDaddy traffic but redirects fine locally on the server for the same site!?

     

    Any ideas what I am missing?


    Any help would be much appreciated.

    Thanks.

    2 REPLIES 2
    Highlighted
    Community Manager
    Community Manager

    Re: Apache2 Linux

    Hi @dbm997. Thanks for being part of GoDaddy Community! I've moved your post to our Developer and Cloud board as this is a somewhat advanced question. Hopefully, that will help you get an answer. 

     

    My only thought was that maybe this is due to your ISP blocking port 80 traffic. I know many providers do this for inbound traffic unless you specifically pay to have a static IP address. You may have already checked that, but it wasn't clear to me based on what you mentioned in your post. Anyway, I hope you're able to get this resolved. If you're able to figure it out, please follow up here so others can benefit from your experience. 

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.
    Highlighted

    Re: Apache2 Linux

    Hey @dbm997,

    Can you confirm with your ISP allows port 80? most do not unless you have business account. Cox and Century Link definitely don't allow it.

     

    Can you also post your config file code? that may shed some light as well.

     

    and, is the version of Mint you are using still based on Debian, or Ubuntu?

     

    Thanks!



    You code more, you live long time