cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Enable INTL extension php

Fatal error: Class 'Locale' not found in /home/content/09/11801609/html/cshopslabuser/lib/core.class.php on line 33

 

I read that the solution was to enable INTL php extension 

 

I need urgent help

2 ACCEPTED SOLUTIONS
Community Manager

Hi @Waqasgk. Thanks for being part of GoDaddy Community! If you have a cPanel account, this is something you can manage. Access your cPanel dashboard then go to Software>Select PHP Version. From there, you should see the option to enable INTL. It should be enabled by default. You can click save to enable it if it isn't already. 

intl.jpg

 

 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

View solution in original post

Hi @Waleed0

Check out the article here, which should help you out. 

KayJay - GoDaddy | Community Moderator
24/7 support available at x.co/247support

View solution in original post

10 REPLIES 10
New

I need the same question answered!

No PHP 7 INTL extension found.  Having same issue. Any thoughts?

i need to enable intl extension under my Deluxe Linux Hosting  

 

Please help!!!!!!!!!!!!!!!!!

Community Manager

Hi @Waqasgk. Thanks for being part of GoDaddy Community! If you have a cPanel account, this is something you can manage. Access your cPanel dashboard then go to Software>Select PHP Version. From there, you should see the option to enable INTL. It should be enabled by default. You can click save to enable it if it isn't already. 

intl.jpg

 

 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

View solution in original post

That is easily done when using the cPanel.

 

I am still having the Classic Linux Web Hosting.

I tried to used a custom php.ini and it's loading the file, however, I am not sure what is the name of the INTL library or its path.

 

which one if the correct one ??

 

extension=intl.so
extension=php_intl.so
extension=php5.6-intl.so
extension=php5.6_intl.so
extension=php-intl.so

 

appreciate any help in this regard.

 

Thanks,

Hi @Waleed0

Check out the article here, which should help you out. 

KayJay - GoDaddy | Community Moderator
24/7 support available at x.co/247support

View solution in original post

I checked the article and it is matching what I have done.

I am still unable to load the INTL extension and I am getting the error below:

 

[08-Sep-2018 12:03:41 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/php5_6/lib/php/extensions/no-debug-non-zts-20131226/intl.so' - /usr/local/php5_6/lib/php/extensions/no-debug-non-zts-20131226/intl.so: cannot open shared object file: No such file or directory in Unknown on line 0

I am facing same intl extension error and the customer care executive said, ask with your web developer. As this message clearly said contact with your hosting company.

 

I am using Godaddy Plesk hosting, please help!

 

Error:

"You must enable the intl extension to use our script. Please ask your hosting company to enable it."

Hi JesseW,

 

Please suggest where I can find these settings in Godaddy Plesk Hosting ?

 

I am facing below error:

 

"You must enable the intl extension to use our script. Please ask your hosting company to enable it."

 

Kindly try to reply me asap.

Same problem here. INTL extension not found on Plesk. Please help!!!