cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New

MySQL extension which is required by WordPress.

Anyone know how to fix this error? 

 

The full error is "Your PHP installation appears to be missing the MySQL extension which is required by WordPress."

4 REPLIES 4
Helper VI
Helper VI

Re: MySQL extension which is required by WordPress.

@sulamo if you are on a cpanel plan, you should go to "Select PHP version" under the Software section. Then you can see what extensions you have enabled, and you can enable/disable the ones you want.

 

In your case you should enable mysql and mysqli.

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄
New

Re: MySQL extension which is required by WordPress.


@jpablo wrote:

@sulamo if you are on a cpanel plan, you should go to "Select PHP version" under the Software section. Then you can see what extensions you have enabled, and you can enable/disable the ones you want.

 

In your case you should enable mysql and mysqli.

 

Hope it helps!


I enabled mysql and mysqli but it still showing the same error. Please help!

Re: MySQL extension which is required by WordPress.

hi

please check your current php version 

New

Re: MySQL extension which is required by WordPress.

Hello,

 

On Godaddy, My website folder and database got deleted. I restored the folders and database through backup. It got restored successfully. But the website is not showing up. It is flashing following error

Your PHP installation appears to be missing the MySQL extension which is required by WordPress


I changed the PHP version to native 5.4. Now the error is

Warning: mysql_connect(): No such file or directory in /home/xxxx.com/public_html/demo/wp-includes/wp-db.php on line 1585

Error establishing a database connection

Can somebody help me out to fix the issue.

Thank you for your help

regards,

Manoj